summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/grpcio-tools/grpcio-tools-1.16.0.ebuild')
-rw-r--r--dev-python/grpcio-tools/grpcio-tools-1.16.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/grpcio-tools/grpcio-tools-1.16.0.ebuild b/dev-python/grpcio-tools/grpcio-tools-1.16.0.ebuild
new file mode 100644
index 000000000000..1cc3d8eb6721
--- /dev/null
+++ b/dev-python/grpcio-tools/grpcio-tools-1.16.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Protobuf code generator for gRPC"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ !<net-libs/grpc-1.16.0[tools]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+}