summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild')
-rw-r--r--dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..26eee5426a19
--- /dev/null
+++ b/dev-python/hachoir-core/hachoir-core-1.3.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Core of Hachoir framework: parse and edit binary files"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-core http://pypi.python.org/pypi/hachoir-core"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ mydistutilsargs=( --setuptools )
+}
+
+python_test() {
+ "${PYTHON}" test_doc.py || die "Tests fail with ${EPYTHON}"
+}