summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpbin/httpbin-0.4.0.ebuild')
-rw-r--r--dev-python/httpbin/httpbin-0.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/httpbin/httpbin-0.4.0.ebuild b/dev-python/httpbin/httpbin-0.4.0.ebuild
new file mode 100644
index 000000000000..e80b3b2d95aa
--- /dev/null
+++ b/dev-python/httpbin/httpbin-0.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP Request and Response Service"
+HOMEPAGE="https://github.com/Runscope/httpbin http://pypi.python.org/pypi/httpbin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/werkzeug[${PYTHON_USEDEP}] )"
+
+# Not included
+# Someone needs to file a bug upstream
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_httpbin.py || die
+}