summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis/hypothesis-1.18.1.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-1.18.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-1.18.1.ebuild b/dev-python/hypothesis/hypothesis-1.18.1.ebuild
new file mode 100644
index 000000000000..839322f72dcd
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-1.18.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}