summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/hypothesis/hypothesis-6.46.2.ebuild b/dev-python/hypothesis/hypothesis-6.46.2.ebuild
index 758bc099894a..d8d3c343338c 100644
--- a/dev-python/hypothesis/hypothesis-6.46.2.ebuild
+++ b/dev-python/hypothesis/hypothesis-6.46.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+),sqlite"
inherit distutils-r1 multiprocessing optfeature
@@ -39,6 +39,12 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # unblock py3.11 betas
+ sed -i -e '/release.*alpha/d' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
# subtests are broken by warnings from random plugins
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1