summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jikanpy')
-rw-r--r--dev-python/jikanpy/jikanpy-4.3.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/jikanpy/jikanpy-4.3.2.ebuild b/dev-python/jikanpy/jikanpy-4.3.2.ebuild
index 7723c4ff2c19..e806908846aa 100644
--- a/dev-python/jikanpy/jikanpy-4.3.2.ebuild
+++ b/dev-python/jikanpy/jikanpy-4.3.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python wrapper for jikan.moe API."
@@ -14,14 +14,14 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-BDEPEND="
- test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )
-"
-
RDEPEND="
dev-python/aiohttp[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
"
+BDEPEND="test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+)"
distutils_enable_tests pytest