summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonmerge/jsonmerge-1.4.0.ebuild')
-rw-r--r--dev-python/jsonmerge/jsonmerge-1.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jsonmerge/jsonmerge-1.4.0.ebuild b/dev-python/jsonmerge/jsonmerge-1.4.0.ebuild
new file mode 100644
index 000000000000..e6ef174e7342
--- /dev/null
+++ b/dev-python/jsonmerge/jsonmerge-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Merge a series of JSON documents"
+HOMEPAGE="https://github.com/avian2/jsonmerge/ https://pypi.python.org/pypi/jsonmerge/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${REPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH="${PWD}" python -m unittest \
+ $(find tests -name 'test_*.py' | LC_ALL=C sort | sed -e 's:/:.:' -e 's:.py$::') || die
+}