summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jwcrypto/jwcrypto-0.7.0.ebuild')
-rw-r--r--dev-python/jwcrypto/jwcrypto-0.7.0.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild b/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild
deleted file mode 100644
index 19f2c548671d..000000000000
--- a/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
-
-HOMEPAGE="https://github.com/latchset/jwcrypto"
-SRC_URI="https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/cryptography-1.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pep8[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- py.test -v || die
-}