summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ldap3/ldap3-2.4.1.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-2.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-2.4.1.ebuild b/dev-python/ldap3/ldap3-2.4.1.ebuild
new file mode 100644
index 000000000000..0b8cb7a8fa84
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v -s test || die
+}