summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/llfuse/llfuse-1.3.5.ebuild')
-rw-r--r--dev-python/llfuse/llfuse-1.3.5.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/llfuse/llfuse-1.3.5.ebuild b/dev-python/llfuse/llfuse-1.3.5.ebuild
deleted file mode 100644
index 9ddaed77c9f4..000000000000
--- a/dev-python/llfuse/llfuse-1.3.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the low-level FUSE API"
-HOMEPAGE="https://github.com/python-llfuse/python-llfuse/ https://pypi.org/project/llfuse/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-fs/fuse-2.8.0:0
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-apps/attr
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}