summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lupy/lupy-0.2.1-r2.ebuild')
-rw-r--r--dev-python/lupy/lupy-0.2.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/lupy/lupy-0.2.1-r2.ebuild b/dev-python/lupy/lupy-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..00900b7369a9
--- /dev/null
+++ b/dev-python/lupy/lupy-0.2.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Lupy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lupy is a is a full-text indexer and search engine written in Python"
+HOMEPAGE="http://divmod.org/projects/lupy http://pypi.python.org/pypi/Lupy"
+SRC_URI="mirror://sourceforge/lupy/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ~s390 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="changelog.txt releasenotes.txt"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}