summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs/mkdocs-0.11.1-r1.ebuild')
-rw-r--r--dev-python/mkdocs/mkdocs-0.11.1-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/mkdocs/mkdocs-0.11.1-r1.ebuild b/dev-python/mkdocs/mkdocs-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..fed5d4d0089e
--- /dev/null
+++ b/dev-python/mkdocs/mkdocs-0.11.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Project documentation with Markdown."
+HOMEPAGE="http://www.mkdocs.org"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/ghp-import-0.4.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e "20s/,[^']*//" \
+ -i setup.py
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" -m mkdocs.main build || die "failed to build documentation"
+ fi
+}
+
+python_test() {
+ nosetests mkdocs/test.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( site/. )
+
+ distutils-r1_python_install_all
+}