summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/more-itertools')
-rw-r--r--dev-python/more-itertools/more-itertools-8.12.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/more-itertools/more-itertools-8.12.0-r1.ebuild b/dev-python/more-itertools/more-itertools-8.12.0-r1.ebuild
new file mode 100644
index 000000000000..5608cb603088
--- /dev/null
+++ b/dev-python/more-itertools/more-itertools-8.12.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="More routines for operating on iterables, beyond itertools"
+HOMEPAGE="https://pypi.org/project/more-itertools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests unittest
+
+src_configure() {
+ grep -q '\[build-system\]' pyproject.toml &&
+ die "Upstream added [build-system] to pyproject.toml, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "more_itertools"
+ version = "${PV}"
+ description = "More routines for operating on iterables, beyond itertools"
+ EOF
+}