summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbsphinx/nbsphinx-0.7.0.ebuild')
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.7.0.ebuild b/dev-python/nbsphinx/nbsphinx-0.7.0.ebuild
new file mode 100644
index 000000000000..45662ca939f9
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="https://github.com/spatialaudio/nbsphinx/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "