summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numexpr/numexpr-2.4.ebuild')
-rw-r--r--dev-python/numexpr/numexpr-2.4.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/numexpr/numexpr-2.4.ebuild b/dev-python/numexpr/numexpr-2.4.ebuild
deleted file mode 100644
index 83c7c988eac9..000000000000
--- a/dev-python/numexpr/numexpr-2.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( ANNOUNCE.rst AUTHORS.txt README.rst RELEASE_NOTES.rst )
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- local ext
- use amd64 && ext=_lp64
- cat <<- EOF > "${S}"/site.cfg
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- EOF
- fi
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib* || die
- "${PYTHON}" -c "import numexpr; numexpr.test()" || die
-}