summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/optcomplete/optcomplete-1.2-r1.ebuild')
-rw-r--r--dev-python/optcomplete/optcomplete-1.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/optcomplete/optcomplete-1.2-r1.ebuild b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
new file mode 100644
index 000000000000..cae27380d2f6
--- /dev/null
+++ b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Shell completion self-generator for Python"
+HOMEPAGE="http://furius.ca/optcomplete/ http://pypi.python.org/pypi/optcomplete"
+SRC_URI="http://furius.ca/downloads/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-linux"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use examples && local EXAMPLES=( bin/. )
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}