summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/packaging-15.3-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-15.3-r2.ebuild b/dev-python/packaging/packaging-15.3-r2.ebuild
new file mode 100644
index 000000000000..6d77cb96a087
--- /dev/null
+++ b/dev-python/packaging/packaging-15.3-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-setuptools.patch )
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}