summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest4
-rw-r--r--dev-python/peewee/metadata.xml8
-rw-r--r--dev-python/peewee/peewee-2.5.1.ebuild38
-rw-r--r--dev-python/peewee/peewee-2.6.0.ebuild39
-rw-r--r--dev-python/peewee/peewee-2.6.1.ebuild39
-rw-r--r--dev-python/peewee/peewee-2.6.2.ebuild39
6 files changed, 167 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
new file mode 100644
index 000000000000..4dee79104abd
--- /dev/null
+++ b/dev-python/peewee/Manifest
@@ -0,0 +1,4 @@
+DIST peewee-2.5.1.tar.gz 556698 SHA256 65f426a5eb403b1427e97732ca36db4edba3581334fa8de68bcf82068e02169e SHA512 f6a014f7a28f31fa1459f192ea376dc8df39b969e032cc875e9ba48d59a4d20994cc20d7bf797976a220d2a5e53a2f8637a1efe37f530224f09c87b739768902 WHIRLPOOL 8ecfd5dc922c027c67f421015574334fa33153c552721d61c5d844dc46b8dd4d164061d382344422d4bab1d0622d45700012b8ec574e952c921198cc841456d4
+DIST peewee-2.6.0.tar.gz 558595 SHA256 724c4dbd81062a21562d164b828abec7c506f1a49ef5ece41f015bd669ddf447 SHA512 6d9c7ef89ac61bb294d7a9dd1249cf4a089f4f83b2680b86964dd8b67dcdbd0cf597cf897d66e141866148838e34ecd4e1d1ede10d1cc01db41318a0ac09cb71 WHIRLPOOL 357f55fbc95b3600d1a758b1192e88fd2b9e570b00468e2c98490188dd28c415bb36932bd38095c6c1db79217085eb641fea9a87ff1a9ee51d546d0e7525940d
+DIST peewee-2.6.1.tar.gz 567141 SHA256 e5162d9c8043ef36d163b594a53a1095f6b4fe7589ec5427896f77a94d59445b SHA512 84f3b05509fda503265796fadf3b029a96bc9500073e8e5f861d0d6c69d9dcf6a3a0a3efefbbfc1c3ac3878d14a004e72b5d0fa11008d1ac0ea23ce8762c248d WHIRLPOOL de1b72f141bd6da97e3d7faaefe969024c73e0db763ec37b68be948df5cdd0d2e97a1a4135a9b1bab17b91f28d91a4d598a97ab75291fe0b0805e82cd20be79a
+DIST peewee-2.6.2.tar.gz 574383 SHA256 2e9ee19d6beef477a14436be6bc173d2472f6ddc0afb28763fd5a4e8fb287e35 SHA512 a38b46d39c04106ddc047f56cd8ebbf48218547a3d8f7dec693f99b9c9b82df505c1948f91155177a00797765d0758ffea79d5ee5da5cf9b59adcd4b2e269483 WHIRLPOOL bff5aa5ef22f08cda83a70b933a4e5734ffb5adaa5388b399694ed8246a92b89edecb78375e6d561aafa6768f7d22bcd3cab1623fd43665be5a6712893b6f9ee
diff --git a/dev-python/peewee/metadata.xml b/dev-python/peewee/metadata.xml
new file mode 100644
index 000000000000..dfaea1228fe1
--- /dev/null
+++ b/dev-python/peewee/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">coleifer/peewee</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/peewee/peewee-2.5.1.ebuild b/dev-python/peewee/peewee-2.5.1.ebuild
new file mode 100644
index 000000000000..143f63ab712e
--- /dev/null
+++ b/dev-python/peewee/peewee-2.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/peewee/peewee-2.6.0.ebuild b/dev-python/peewee/peewee-2.6.0.ebuild
new file mode 100644
index 000000000000..9070a3191b33
--- /dev/null
+++ b/dev-python/peewee/peewee-2.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/peewee/peewee-2.6.1.ebuild b/dev-python/peewee/peewee-2.6.1.ebuild
new file mode 100644
index 000000000000..9070a3191b33
--- /dev/null
+++ b/dev-python/peewee/peewee-2.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/peewee/peewee-2.6.2.ebuild b/dev-python/peewee/peewee-2.6.2.ebuild
new file mode 100644
index 000000000000..9070a3191b33
--- /dev/null
+++ b/dev-python/peewee/peewee-2.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}