summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch')
-rw-r--r--dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch b/dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch
new file mode 100644
index 000000000000..b73681831a6f
--- /dev/null
+++ b/dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch
@@ -0,0 +1,16 @@
+diff --git a/setup.py b/setup.py
+index 761d552c..c4a55092 100755
+--- a/setup.py
++++ b/setup.py
+@@ -435,6 +435,11 @@ class pil_build_ext(build_ext):
+ _add_directory(include_dirs,
+ os.path.join(best_path, 'include'))
+
++ # The logic above fails in many cases (such as pypy builds) and we fix
++ # it here by making sure we look in standard places first.
++ library_dirs = ['/usr/lib64', '/usr/lib'] + library_dirs
++ include_dirs = ['/usr/include'] + include_dirs
++
+ #
+ # insert new dirs *before* default libs, to avoid conflicts
+ # between Python PYD stub libs and real libraries