summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/metadata.xml9
-rw-r--r--dev-python/prettytable/prettytable-0.7.1-r1.ebuild25
-rw-r--r--dev-python/prettytable/prettytable-0.7.2.ebuild25
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
new file mode 100644
index 000000000000..011de67919a4
--- /dev/null
+++ b/dev-python/prettytable/Manifest
@@ -0,0 +1,2 @@
+DIST prettytable-0.7.1.tar.bz2 21499 SHA256 599bc5b4b9602e28294cf795733c889c26dd934aa7e0ee9cff9b905d4fbad188 SHA512 1a7aa604f608483b107401ddca9721ddea673ea1415d2a514948f7399835784e0a9025f0e5236f4109890e5924da345bd111893200730501b496c136465c204f WHIRLPOOL cbde4e7053eb82749a21f1ac7e0a9ab7368f9dfbe64f0e434da085dc30f24931110e87c508c500bb340adec6d928dae53f1652d1601a5718311a9e414a2b789c
+DIST prettytable-0.7.2.tar.bz2 21755 SHA256 853c116513625c738dc3ce1aee148b5b5757a86727e67eff6502c7ca59d43c36 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71 WHIRLPOOL 1b27332ea8b2c83ec13b981508f429881bacacb87ac4a8c51a42b6071daa6d1278a48f3359547efae2c7f9eb1fe5d6b13e2d4232543722aa3aab1f30f9fccfbe
diff --git a/dev-python/prettytable/metadata.xml b/dev-python/prettytable/metadata.xml
new file mode 100644
index 000000000000..70d493aab966
--- /dev/null
+++ b/dev-python/prettytable/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <upstream>
+ <remote-id type="google-code">prettytable</remote-id>
+ <remote-id type="pypi">PrettyTable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/prettytable/prettytable-0.7.1-r1.ebuild b/dev-python/prettytable/prettytable-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..07d8caad35b0
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/prettytable/prettytable-0.7.2.ebuild b/dev-python/prettytable/prettytable-0.7.2.ebuild
new file mode 100644
index 000000000000..e385645ea2ed
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}