summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ptyprocess/ptyprocess-0.7.0.ebuild')
-rw-r--r--dev-python/ptyprocess/ptyprocess-0.7.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/ptyprocess/ptyprocess-0.7.0.ebuild b/dev-python/ptyprocess/ptyprocess-0.7.0.ebuild
new file mode 100644
index 000000000000..b1ca6b3d3d53
--- /dev/null
+++ b/dev-python/ptyprocess/ptyprocess-0.7.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Run a subprocess in a pseudo terminal"
+HOMEPAGE="https://github.com/pexpect/ptyprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest