summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py2neo/py2neo-2.0.7.ebuild')
-rw-r--r--dev-python/py2neo/py2neo-2.0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/py2neo/py2neo-2.0.7.ebuild b/dev-python/py2neo/py2neo-2.0.7.ebuild
new file mode 100644
index 000000000000..54603236bea5
--- /dev/null
+++ b/dev-python/py2neo/py2neo-2.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple and pragmatic library which accesses the Neo4j graph database"
+HOMEPAGE="http://py2neo.org"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_compile() {
+ # https://github.com/nigelsmall/py2neo/issues/380
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}