summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyao/pyao-0.82-r3.ebuild')
-rw-r--r--dev-python/pyao/pyao-0.82-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyao/pyao-0.82-r3.ebuild b/dev-python/pyao/pyao-0.82-r3.ebuild
new file mode 100644
index 000000000000..12be8cb0e19f
--- /dev/null
+++ b/dev-python/pyao/pyao-0.82-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the libao library"
+HOMEPAGE="http://www.andrewchatham.com/pyogg/"
+SRC_URI="http://www.andrewchatham.com/pyogg/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc -sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libao-1.0.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-new_api.patch )
+
+python_compile() {
+ "${PYTHON}" config_unix.py || die
+ distutils-r1_python_compile
+}