summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycryptodome/pycryptodome-3.4.5.ebuild')
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.4.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild b/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild
new file mode 100644
index 000000000000..d6eebef2a142
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.4.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://github.com/Legrandin/pycryptodome"
+SRC_URI="https://github.com/Legrandin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/gmp:0
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ !dev-python/pycrypto"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}