summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2/pygit2-0.24.2.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.24.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.24.2.ebuild b/dev-python/pygit2/pygit2-0.24.2.ebuild
new file mode 100644
index 000000000000..d00efa61c561
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.24.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}