summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest3
-rw-r--r--dev-python/pygit2/metadata.xml12
-rw-r--r--dev-python/pygit2/pygit2-0.20.3.ebuild23
-rw-r--r--dev-python/pygit2/pygit2-0.21.4-r1.ebuild26
-rw-r--r--dev-python/pygit2/pygit2-0.22.1.ebuild29
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
new file mode 100644
index 000000000000..a765ba5ad331
--- /dev/null
+++ b/dev-python/pygit2/Manifest
@@ -0,0 +1,3 @@
+DIST pygit2-0.20.3.tar.gz 141887 SHA256 2957db7d9616db910e9274051fbfe66a496b910113548fbf2a7acdeef01e9ef9 SHA512 13355f2eccb591c7e1e18f66724aa0b68b94e65580aa20464e8669a8f54844557902f029127a9c5e50c3d4dafdc504f1d3aca65c0d26d9f147ff08eab2b002dc WHIRLPOOL a4496cb3dd2799c77240e1eae9c06f167727cb5948081da6f8864feb5ab38a046f8382e994dd3cdf28f4ac8b9e7675b3671b4369a8268f7f09b3c11d3e8bee3d
+DIST pygit2-0.21.4.tar.gz 417750 SHA256 1952332b48e87e918bc807305220075bfb611c96fbc529a43c78d73fdce25593 SHA512 835369ec9302d27ed361ccf3317fece4192e765c5e6e014ed6dd87cba38fe833eff3ba36558aa2951f42542408e3dba07777937aedaf539583db4454198d3112 WHIRLPOOL 90204b7dd28216ddfa82667e246bdaf154b19753b6382b7467a3cae85140a4672342045ba2713ba0eba8e0add5b6facd2ae4f72a0214d3eca0b49acccf14744f
+DIST pygit2-0.22.1.tar.gz 451351 SHA256 54b6e229ca2bf87efe4b5b8279d8f355b8c49613f0b8cbe7e0c1c98c001c39e0 SHA512 8ffcea4a94ca4667112b79e4adda43a75a9b677e609af528f79d4e6f8e84873a4c8478b89743d1de35d28ae00b1254e2287cd912776d96e3bf6a0030477e86a3 WHIRLPOOL 8eeec7ae2bc29264022f59067f93cb5375ead2285a30c27bd9f0c48c1be2b308c5413a3b3b8ede4a9be152727978971b0a6d2f23aeafc7f985ee0eeaf29aa72b
diff --git a/dev-python/pygit2/metadata.xml b/dev-python/pygit2/metadata.xml
new file mode 100644
index 000000000000..42dac9c9129a
--- /dev/null
+++ b/dev-python/pygit2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">libgit2/pygit2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygit2/pygit2-0.20.3.ebuild b/dev-python/pygit2/pygit2-0.20.3.ebuild
new file mode 100644
index 000000000000..7725f47e1358
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.20.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=dev-libs/libgit2-$(get_version_component_range 1-2)*"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pygit2/pygit2-0.21.4-r1.ebuild b/dev-python/pygit2/pygit2-0.21.4-r1.ebuild
new file mode 100644
index 000000000000..3fe1fee0bd12
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.21.4-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pygit2/pygit2-0.22.1.ebuild b/dev-python/pygit2/pygit2-0.22.1.ebuild
new file mode 100644
index 000000000000..2f6c247de2ad
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.22.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+# infinite hang
+RESTRICT="test"
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}