summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pylzma/pylzma-0.4.4-r1.ebuild')
-rw-r--r--dev-python/pylzma/pylzma-0.4.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pylzma/pylzma-0.4.4-r1.ebuild b/dev-python/pylzma/pylzma-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..b861f22d8590
--- /dev/null
+++ b/dev-python/pylzma/pylzma-0.4.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+# hashlib module required.
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the LZMA compression library"
+HOMEPAGE="http://www.joachim-bauch.de/projects/python/pylzma/ http://pypi.python.org/pypi/pylzma"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-python/m2crypto[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=(doc/usage.txt readme.txt)
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}