summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2021.2.6.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.6.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pyopencl/pyopencl-2021.2.6.ebuild b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
new file mode 100644
index 000000000000..9c4b6ac92a78
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}