summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyotherside/pyotherside-1.5.1.ebuild')
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.5.1.ebuild b/dev-python/pyotherside/pyotherside-1.5.1.ebuild
new file mode 100644
index 000000000000..b30d8b2501dc
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="http://github.com/thp/pyotherside http://thp.io/2011/pyotherside"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}