summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyquery/pyquery-1.2.8.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.2.8.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/dev-python/pyquery/pyquery-1.2.8.ebuild b/dev-python/pyquery/pyquery-1.2.8.ebuild
index fa371b17d203..4a02d400e46d 100644
--- a/dev-python/pyquery/pyquery-1.2.8.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,9 +15,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]"
@@ -25,10 +26,10 @@ DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/nose[${PYTHON_USEDEP}] )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_prepare_all() {
# rm known failing tests and tests dependent on restkit
# https://github.com/gawel/pyquery/pull/63/files
@@ -43,3 +44,7 @@ python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}