summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/Manifest2
-rw-r--r--dev-python/pyserial/files/mapping.patch13
-rw-r--r--dev-python/pyserial/files/pyserial-2.5-python-3.patch43
-rw-r--r--dev-python/pyserial/files/pyserial-2.6-list_ports.patch15
-rw-r--r--dev-python/pyserial/metadata.xml8
-rw-r--r--dev-python/pyserial/pyserial-2.6-r1.ebuild22
-rw-r--r--dev-python/pyserial/pyserial-2.7-r1.ebuild38
-rw-r--r--dev-python/pyserial/pyserial-2.7.ebuild22
8 files changed, 163 insertions, 0 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
new file mode 100644
index 000000000000..15b3cbaefdf6
--- /dev/null
+++ b/dev-python/pyserial/Manifest
@@ -0,0 +1,2 @@
+DIST pyserial-2.6.tar.gz 116289 SHA256 049dbcda0cd475d3be903e721d60889ee2cc4ec3b62892a81ecef144196413ed SHA512 41682f8fafb6c5fa9642d3a0a3d6d0648101c38d157005f9c4e019e55d534953486072caf05647d8828b0e19c8259cc61cac856a570bf09904922ffd175fad2d WHIRLPOOL d632521d4687751f3056eda3ef254d603a7450d09457deed4d12136ee690d8af8d9aea1b8f8aebe9ec877a00bec5fa54933d2bff0cec281de0b676dde3d86e55
+DIST pyserial-2.7.tar.gz 122081 SHA256 3542ec0838793e61d6224e27ff05e8ce4ba5a5c5cc4ec5c6a3e8d49247985477 SHA512 3fc8d9425a47ebcd37db1fcc58182854b48c9abd6642f35fba2d21458d864ae448105d704dc0d880832ba7516fa16f108f24363bd5fa9f083ea79a4ac614339b WHIRLPOOL ae6b4df86220617f7fbc1f1e4085a7e85dca645a6d84339163b40fc7a15f14b879ef7a729d3d23d0300f9ee04b21d6c24d13a791d520aef3f3ad141c6acd9b68
diff --git a/dev-python/pyserial/files/mapping.patch b/dev-python/pyserial/files/mapping.patch
new file mode 100644
index 000000000000..bd315d98f040
--- /dev/null
+++ b/dev-python/pyserial/files/mapping.patch
@@ -0,0 +1,13 @@
+diff -ur pyserial-2.7.orig/documentation/conf.py pyserial-2.7/documentation/conf.py
+--- documentation/conf.py 2013-10-18 00:29:53.000000000 +0800
++++ documentation/conf.py 2014-03-28 12:41:08.848807687 +0800
+@@ -192,9 +192,3 @@
+
+ # If false, no module index is generated.
+ #latex_use_modindex = True
+-
+-# for external links to standard library
+-intersphinx_mapping = {
+- #~ 'python': ('http://docs.python.org', None),
+- 'py': ('http://docs.python.org', None),
+- }
diff --git a/dev-python/pyserial/files/pyserial-2.5-python-3.patch b/dev-python/pyserial/files/pyserial-2.5-python-3.patch
new file mode 100644
index 000000000000..5ad5c6c80524
--- /dev/null
+++ b/dev-python/pyserial/files/pyserial-2.5-python-3.patch
@@ -0,0 +1,43 @@
+http://pyserial.svn.sourceforge.net/viewvc/pyserial?view=revision&revision=381
+
+--- setup.py
++++ setup.py
+@@ -1,7 +1,13 @@
+-# setup.py for pyserial
++# setup.py for pySerial
+ #
+-# windows installer:
+-# python setup.py bdist_wininst
++# Windows installer:
++# "python setup.py bdist_wininst"
++#
++# Direct install (all systems):
++# "python setup.py install"
++#
++# For Python 3.x use the corresponding Python executable,
++# e.g. "python3 setup.py ..."
+
+ import sys
+
+@@ -9,10 +15,12 @@
+
+ try:
+ from distutils.command.build_py import build_py_2to3 as build_py
++ from distutils.command.build_scripts import build_scripts_2to3 as build_scripts
+ except ImportError:
+ if sys.version_info >= (3, 0):
+ raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
+ from distutils.command.build_py import build_py
++ from distutils.command.build_scripts import build_scripts
+ suffix = ""
+ else:
+ suffix = "-py3k"
+@@ -60,7 +68,7 @@
+ 'Topic :: Terminals :: Serial',
+ ],
+ platforms = 'any',
+- cmdclass = {'build_py': build_py},
++ cmdclass = {'build_py': build_py, 'build_scripts': build_scripts},
+
+ scripts = ['examples/miniterm.py'],
+ )
diff --git a/dev-python/pyserial/files/pyserial-2.6-list_ports.patch b/dev-python/pyserial/files/pyserial-2.6-list_ports.patch
new file mode 100644
index 000000000000..cd3b4ef8e322
--- /dev/null
+++ b/dev-python/pyserial/files/pyserial-2.6-list_ports.patch
@@ -0,0 +1,15 @@
+http://sourceforge.net/p/pyserial/patches/26/
+Index: trunk/pyserial/serial/tools/list_ports_posix.py
+===================================================================
+--- trunk/pyserial/serial/tools/list_ports_posix.py (revision 439)
++++ trunk/pyserial/serial/tools/list_ports_posix.py (working copy)
+@@ -64,7 +64,8 @@
+ )
+
+ def usb_lsusb_string(sysfs_path):
+- bus, dev = os.path.basename(os.path.realpath(sysfs_path)).split('-')
++ base = os.path.basename(os.path.realpath(sysfs_path))
++ bus, dev = base.split('-')
+ try:
+ desc = popen(['lsusb', '-v', '-s', '%s:%s' % (bus, dev)])
+ # descriptions from device
diff --git a/dev-python/pyserial/metadata.xml b/dev-python/pyserial/metadata.xml
new file mode 100644
index 000000000000..b52569ee11b8
--- /dev/null
+++ b/dev-python/pyserial/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyserial</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyserial/pyserial-2.6-r1.ebuild b/dev-python/pyserial/pyserial-2.6-r1.ebuild
new file mode 100644
index 000000000000..36fa39365426
--- /dev/null
+++ b/dev-python/pyserial/pyserial-2.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port Extension"
+HOMEPAGE="http://pyserial.sourceforge.net/ http://sourceforge.net/projects/pyserial/ http://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+DOCS=( CHANGES.txt README.txt )
+PATCHES=( "${FILESDIR}"/${PN}-${PV}-list_ports.patch )
diff --git a/dev-python/pyserial/pyserial-2.7-r1.ebuild b/dev-python/pyserial/pyserial-2.7-r1.ebuild
new file mode 100644
index 000000000000..ae44b85b8ee0
--- /dev/null
+++ b/dev-python/pyserial/pyserial-2.7-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port Extension"
+HOMEPAGE="http://pyserial.sourceforge.net/ http://sourceforge.net/projects/pyserial/ http://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=""
+PATCHES=( "${FILESDIR}"/mapping.patch )
+DOCS=( CHANGES.txt README.txt )
+
+python_prepare_all() {
+ # Usual avoid d'loading un-needed objects.inv file
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyserial/pyserial-2.7.ebuild b/dev-python/pyserial/pyserial-2.7.ebuild
new file mode 100644
index 000000000000..fb49cf7bc823
--- /dev/null
+++ b/dev-python/pyserial/pyserial-2.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port Extension"
+HOMEPAGE="http://pyserial.sourceforge.net/ http://sourceforge.net/projects/pyserial/ http://pypi.python.org/pypi/pyserial"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( CHANGES.txt README.txt )