summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysrt/pysrt-1.0.1.ebuild')
-rw-r--r--dev-python/pysrt/pysrt-1.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-1.0.1.ebuild b/dev-python/pysrt/pysrt-1.0.1.ebuild
new file mode 100644
index 000000000000..2c3b4884d4d8
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
+"
+
+# https://github.com/byroot/pysrt/issues/42
+RESTRICT="test"
+
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}