summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
new file mode 100644
index 000000000000..30042a6adbdf
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-1.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="https://github.com/davehunt/pytest-metadata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test || die
+}