summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-3.4.2.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pytest/pytest-3.4.2.ebuild b/dev-python/pytest/pytest-3.4.2.ebuild
index 1f02558ba400..335e6ee56472 100644
--- a/dev-python/pytest/pytest-3.4.2.ebuild
+++ b/dev-python/pytest/pytest-3.4.2.ebuild
@@ -55,6 +55,11 @@ python_prepare_all() {
# https://bugs.gentoo.org/598442
rm testing/test_pdb.py || die
+ # broken and disabled upstream
+ # https://github.com/pytest-dev/pytest/commit/321f66f71148c978c1bf45dace61886b5e263bd4
+ sed -i -e 's:test_wrapped_getfuncargnames_patching:_&:' \
+ testing/python/integration.py || die
+
distutils-r1_python_prepare_all
}