summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild')
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..a0d367fc8202
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py check
+}