summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-docs/python-docs-3.5.4.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.5.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.5.4.ebuild b/dev-python/python-docs/python-docs-3.5.4.ebuild
new file mode 100644
index 000000000000..c82d0d92315b
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.5.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}" || die
+ doenvd "60python-docs-${SLOT}"
+}