summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-etcd/python-etcd-0.3.2.ebuild')
-rw-r--r--dev-python/python-etcd/python-etcd-0.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-etcd/python-etcd-0.3.2.ebuild b/dev-python/python-etcd/python-etcd-0.3.2.ebuild
new file mode 100644
index 000000000000..f55779b0265f
--- /dev/null
+++ b/dev-python/python-etcd/python-etcd-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python client for etcd"
+HOMEPAGE="https://github.com/jplana/python-etcd"
+SRC_URI="https://github.com/jplana/python-etcd/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/urllib3-1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"