summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-evdev/python-evdev-1.1.2.ebuild')
-rw-r--r--dev-python/python-evdev/python-evdev-1.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-evdev/python-evdev-1.1.2.ebuild b/dev-python/python-evdev/python-evdev-1.1.2.ebuild
new file mode 100644
index 000000000000..69f32c6049cd
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.org/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ distutils-r1_python_compile build_ecodes \
+ --evdev-headers \
+ "${SYSROOT}"/usr/include/linux/input.h:"${SYSROOT}"/usr/include/linux/input-event-codes.h
+}