summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild')
-rw-r--r--dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..0b0fb09e45c9
--- /dev/null
+++ b/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="https://launchpad.net/python-fastimport"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ local test_runner=( "${PYTHON}" -m unittest )
+
+ if [[ ${EPYTHON} == python2.6 ]]; then
+ test_runner=( unit2 )
+ fi
+
+ "${test_runner[@]}" fastimport.tests.test_suite \
+ || die "Tests fail with ${EPYTHON}"
+}