summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-cache/requests-cache-0.4.12.ebuild')
-rw-r--r--dev-python/requests-cache/requests-cache-0.4.12.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/requests-cache/requests-cache-0.4.12.ebuild b/dev-python/requests-cache/requests-cache-0.4.12.ebuild
deleted file mode 100644
index fbebceefaad3..000000000000
--- a/dev-python/requests-cache/requests-cache-0.4.12.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-HOMEPAGE="https://pypi.org/project/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-# Portage only has versions of request >= minimum border
-RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Testsuite excels in tests connecting to the network via local server daemons
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}