summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ropeide')
-rw-r--r--dev-python/ropeide/Manifest1
-rw-r--r--dev-python/ropeide/metadata.xml8
-rw-r--r--dev-python/ropeide/ropeide-1.5.1-r2.ebuild28
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ropeide/Manifest b/dev-python/ropeide/Manifest
new file mode 100644
index 000000000000..de15a18cd2d7
--- /dev/null
+++ b/dev-python/ropeide/Manifest
@@ -0,0 +1 @@
+DIST ropeide-1.5.1.tar.gz 88289 SHA256 a590ec73f806e8409c3b53da7a6345232c9b2c0564800921f8bab61160e87a13 SHA512 fbdfc9519e49440c748c4d9fe5e8a3597b983dcee715f92ce3c9d07eb19b1792623dd3a66ee4f43790887848aa85c17b4596b006c4d1c86859c060af69c32dcb WHIRLPOOL 1efe7596c741b928a979c2aeade2df03532d438f26732f1430547739d5e44d0cae4d4d221e604e5f5464e604d7eb3fcde43e0bfbbe2895c224f2fc508faf0fc9
diff --git a/dev-python/ropeide/metadata.xml b/dev-python/ropeide/metadata.xml
new file mode 100644
index 000000000000..cc44ce4146d8
--- /dev/null
+++ b/dev-python/ropeide/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">rope</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ropeide/ropeide-1.5.1-r2.ebuild b/dev-python/ropeide/ropeide-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..a182565c9735
--- /dev/null
+++ b/dev-python/ropeide/ropeide-1.5.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+PYTHON_REQ_USE="tk"
+
+DESCRIPTION="Python refactoring IDE"
+HOMEPAGE="http://rope.sourceforge.net/ropeide.html http://pypi.python.org/pypi/ropeide"
+SRC_URI="mirror://sourceforge/rope/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-python/rope-0.8.4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ if use doc; then
+ dodoc docs/*.txt || die "dodoc failed"
+ fi
+ distutils-r1_python_install_all
+}