summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/s3transfer/s3transfer-0.0.1.ebuild')
-rw-r--r--dev-python/s3transfer/s3transfer-0.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/s3transfer/s3transfer-0.0.1.ebuild b/dev-python/s3transfer/s3transfer-0.0.1.ebuild
new file mode 100644
index 000000000000..eb56624064c1
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon S3 Transfer Manager"
+HOMEPAGE="http://pypi.python.org/pypi/s3transfer"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "