summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scandir/scandir-1.10.0-r3.ebuild')
-rw-r--r--dev-python/scandir/scandir-1.10.0-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/scandir/scandir-1.10.0-r3.ebuild b/dev-python/scandir/scandir-1.10.0-r3.ebuild
new file mode 100644
index 000000000000..ac31277480d8
--- /dev/null
+++ b/dev-python/scandir/scandir-1.10.0-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# Do NOT add Python 3.11 without verifying the C extension is actually built
+# and installed for it!
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.9.patch
+)
+
+python_test() {
+ "${EPYTHON}" test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}