summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shm/shm-1.2.2-r1.ebuild')
-rw-r--r--dev-python/shm/shm-1.2.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/shm/shm-1.2.2-r1.ebuild b/dev-python/shm/shm-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..135c96317432
--- /dev/null
+++ b/dev-python/shm/shm-1.2.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to access System V shared memory and semaphores"
+HOMEPAGE="http://nikitathespider.com/python/shm/"
+SRC_URI="http://nikitathespider.com/python/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-compiler.patch )
+
+python_install_all() {
+ dohtml ReadMe.html
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}