summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-4.9999.ebuild')
-rw-r--r--dev-python/sip/sip-4.9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/sip/sip-4.9999.ebuild b/dev-python/sip/sip-4.9999.ebuild
index 3fe2c1981bd0..4df03eb6f4e8 100644
--- a/dev-python/sip/sip-4.9999.ebuild
+++ b/dev-python/sip/sip-4.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -69,6 +69,10 @@ src_prepare() {
src_configure() {
configuration() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
local myconf=(
"${PYTHON}"
"${S}"/configure.py