summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest3
-rw-r--r--dev-python/six/metadata.xml2
-rw-r--r--dev-python/six/six-1.14.0.ebuild20
-rw-r--r--dev-python/six/six-1.15.0.ebuild20
-rw-r--r--dev-python/six/six-1.16.0-r1.ebuild41
5 files changed, 43 insertions, 43 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 3015599c7eeb..3b56dd088a00 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,2 +1 @@
-DIST six-1.14.0.tar.gz 33857 BLAKE2B 711ef5b79118c1280c9868688869cc475668c248e6b0c2061145818842d5b4c28809d86b1388709af24f6e92fe5926ea6261f1b85c62db749f79664cbad93e4d SHA512 4dea0f4e7961e8b582d665501c65852dc3b73516a0b6f78b0888c8670f1450df58bd3eea418777f41080b842ab6c3d8633be1034bcf920192e5590d5316e2c9e
-DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
+DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
diff --git a/dev-python/six/metadata.xml b/dev-python/six/metadata.xml
index a82f927395e5..8b22e466209f 100644
--- a/dev-python/six/metadata.xml
+++ b/dev-python/six/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
diff --git a/dev-python/six/six-1.14.0.ebuild b/dev-python/six/six-1.14.0.ebuild
deleted file mode 100644
index 2b7b9e966813..000000000000
--- a/dev-python/six/six-1.14.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-distutils_enable_sphinx documentation --no-autodoc
-distutils_enable_tests pytest
diff --git a/dev-python/six/six-1.15.0.ebuild b/dev-python/six/six-1.15.0.ebuild
deleted file mode 100644
index 685f6840a365..000000000000
--- a/dev-python/six/six-1.15.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 2 and 3 compatibility library"
-HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-distutils_enable_sphinx documentation --no-autodoc
-distutils_enable_tests pytest
diff --git a/dev-python/six/six-1.16.0-r1.ebuild b/dev-python/six/six-1.16.0-r1.ebuild
new file mode 100644
index 000000000000..9850b41681e3
--- /dev/null
+++ b/dev-python/six/six-1.16.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="
+ https://github.com/benjaminp/six/
+ https://pypi.org/project/six/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+ ;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'test_six.py::test_move_items[tkinter_tix]'
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}