summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/Manifest1
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/Manifest b/dev-python/sphinxcontrib-httpdomain/Manifest
index 7b834ca82815..e7402d62d9d0 100644
--- a/dev-python/sphinxcontrib-httpdomain/Manifest
+++ b/dev-python/sphinxcontrib-httpdomain/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-httpdomain-1.4.0.tar.gz 12192 SHA256 9db07b047b8799378ae532d6b9b17080035da8d889082ad7f124de0469feeea4 SHA512 85d4d0898a1703a1742755814200253b875795b5f267b08adb00c7d8d7c15c434718ce0f93656e7b698df89c958a9f6f3f3403bdc6d08f6df322fd80371f1d70 WHIRLPOOL 1365183bd1ba9edff7c82c5c509c6d1f4fe36a35a7f88c168755d330217e4bd70600679d8a501fbacc7730901196ae62c2f6487ded513b8efed1a0012d93a1a8
+DIST sphinxcontrib-httpdomain-1.5.0.tar.gz 13981 SHA256 eab097505caee272ca6a313edb2cbc3d2103bb6bcc09923ef43054e238452f6b SHA512 e393690314cb7a7b81207ee42826eb5360ca6cfa8ad1b57c9a8dd5897ed1ed97bad4a46d8348aad9d5f6b6145e5456af629b14973ad2561d5b90b2f8dbf2163a WHIRLPOOL becf70b6b871bdd5e08be168d5b255f312389baee0b91b95aee9ad35150e9f56363ea95023206290b23e6df7b8b5e27326dbf68850349305c433518c22129534
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild
new file mode 100644
index 000000000000..10e5eef85a82
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="http://packages.python.org/sphinxcontrib-httpdomain/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}