summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stapler/stapler-1.0_pre20191215.ebuild')
-rw-r--r--dev-python/stapler/stapler-1.0_pre20191215.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/stapler/stapler-1.0_pre20191215.ebuild b/dev-python/stapler/stapler-1.0_pre20191215.ebuild
new file mode 100644
index 000000000000..41ab59bf764b
--- /dev/null
+++ b/dev-python/stapler/stapler-1.0_pre20191215.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1 vcs-snapshot
+
+# Commit Date: 15th December 2019
+COMMIT="875325103234b4a3ed96a4a5167ff78c291edbff"
+
+DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
+HOMEPAGE="https://github.com/hellerbarde/stapler"
+SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"