summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/statsd/statsd-3.3.0.ebuild')
-rw-r--r--dev-python/statsd/statsd-3.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/statsd/statsd-3.3.0.ebuild b/dev-python/statsd/statsd-3.3.0.ebuild
new file mode 100644
index 000000000000..df10878f5be5
--- /dev/null
+++ b/dev-python/statsd/statsd-3.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple statsd client"
+HOMEPAGE="https://github.com/jsocol/pystatsd https://pypi.org/project/statsd"
+
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}