summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild')
-rw-r--r--dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild b/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild
index 6cc8d2056c05..73c6507eefb9 100644
--- a/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild
+++ b/dev-python/strict-rfc3339/strict-rfc3339-0.6.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
@@ -16,3 +16,10 @@ SLOT="0"
LICENSE="GPL-3+"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
+
+# Not shipped
+RESTRICT=test
+
+python_test() {
+ ${PYTHON} test_strict_rfc3339.py || die
+}